$re = '/\/category\/(\w+\/)?(\d+)/';
$str = 'https://m.aaa.kr/category/outer/55/
https://m.aaa.kr/category/inner/5/
https://m.aaa.kr/product/jacket/3031/category/55/display/1/
https://m.aaa.kr/product/shirts/30/category/5/display/1/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);