#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<texttool.*rect=\"55\,306\,319\,23\"(?:.|\n)*?<\/texttool>)"
Local $sString = " text before<texttool id="468" rect="55,306,319,23">" & @CRLF & _
" <toolstroke />" & @CRLF & _
" <toolcolor />" & @CRLF & _
" <font style="2" size="18" />" & @CRLF & _
" <Text>(Be sure to state the page/problem number.)</Text>" & @CRLF & _
" </texttool> text after" & @CRLF & _
"" & @CRLF & _
"<texttool id="468" rect="5,306,319,23">" & @CRLF & _
" <toolstroke />" & @CRLF & _
" <toolcolor />" & @CRLF & _
" <font style="2" size="18" />" & @CRLF & _
" <Text>(Be sure to state the page/problem number.)</Text>" & @CRLF & _
" </texttool>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")