// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<texttool.*rect=\"55\,306\,319\,23\"(?:.|\n)*?<\/texttool>)"#).unwrap();
let string = " text before<texttool id=\"468\" rect=\"55,306,319,23\">
<toolstroke />
<toolcolor />
<font style=\"2\" size=\"18\" />
<Text>(Be sure to state the page/problem number.)</Text>
</texttool> text after
<texttool id=\"468\" rect=\"5,306,319,23\">
<toolstroke />
<toolcolor />
<font style=\"2\" size=\"18\" />
<Text>(Be sure to state the page/problem number.)</Text>
</texttool>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}