import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<texttool.*rect=\\\"55\\,306\\,319\\,23\\\"(?:.|\\n)*?<\\/texttool>)";
final String string = " text before<texttool id=\"468\" rect=\"55,306,319,23\">\n"
+ " <toolstroke />\n"
+ " <toolcolor />\n"
+ " <font style=\"2\" size=\"18\" />\n"
+ " <Text>(Be sure to state the page/problem number.)</Text>\n"
+ " </texttool> text after\n\n"
+ "<texttool id=\"468\" rect=\"5,306,319,23\">\n"
+ " <toolstroke />\n"
+ " <toolcolor />\n"
+ " <font style=\"2\" size=\"18\" />\n"
+ " <Text>(Be sure to state the page/problem number.)</Text>\n"
+ " </texttool>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}