#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^group\[.*\].car\[.*\]$"
Local $sString = "group[1].car[8]" & @CRLF & _
"group[1].car[9]" & @CRLF & _
"group[1].truck[1]" & @CRLF & _
"group[1].car[10]" & @CRLF & _
"group[1].carVendor[1]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")