$re = '/^group\[.*\].car\[.*\]$/m';
$str = 'group[1].car[8]
group[1].car[9]
group[1].truck[1]
group[1].car[10]
group[1].carVendor[1]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);