package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^group\[.*\].car\[.*\]$`)
var str = `group[1].car[8]
group[1].car[9]
group[1].truck[1]
group[1].car[10]
group[1].carVendor[1]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}