import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^group\\[.*\\].car\\[.*\\]$";
final String string = "group[1].car[8]\n"
+ "group[1].car[9]\n"
+ "group[1].truck[1]\n"
+ "group[1].car[10]\n"
+ "group[1].carVendor[1]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}