re = /^group\[.*\].car\[.*\]$/m
str = 'group[1].car[8]
group[1].car[9]
group[1].truck[1]
group[1].car[10]
group[1].carVendor[1]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end