const regex = new RegExp('^group\\[.*\\].car\\[.*\\]$', 'gm')
const str = `group[1].car[8]
group[1].car[9]
group[1].truck[1]
group[1].car[10]
group[1].carVendor[1]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}