# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\o\{([^}]+)}/<span>\1<\\/span>/gm;t' <<< "hello \o{test} how are you?
hello <span>test</span> how are you?
"