// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\o\{([^}]+)}").unwrap();
let string = "hello \\o{test} how are you?
hello <span>test</span> how are you?
";
let substitution = "<span>\\1<\\/span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}