use strict;
my $str = 'hello \\o{test} how are you?
hello <span>test</span> how are you?
';
my $regex = qr/\\o\{([^}]+)}/mp;
my $subst = '<span>\\1<\\/span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";