using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\o\{([^}]+)}";
string substitution = @"<span>\1<\/span>";
string input = @"hello \o{test} how are you?
hello <span>test</span> how are you?
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}