package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\o\{([^}]+)}`)
var str = `hello \o{test} how are you?
hello <span>test</span> how are you?
`
var substitution = "<span>\1<\/span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}