$re = '/\\\\o\{([^}]+)}/m';
$str = 'hello \\o{test} how are you?
hello <span>test</span> how are you?
';
$subst = "<span>\1<\/span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;