#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)[ \t*]* @property[-]*(read|write|readwrite)?[ \t]+ ([\w\|]*)[ \t]+ ([\$\w]*)"
Local $sString = "@property MyType|string $propertyName" & @CRLF & _
"@property-read MyType|string $property_Name" & @CRLF & _
"@property-write MyType|string $propertyName" & @CRLF & _
"@property-readwrite MyType|string $propertyName"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")