using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ \t*]* @property[-]*(read|write|readwrite)?[ \t]+ ([\w\|]*)[ \t]+ ([\$\w]*)";
string input = @"@property MyType|string $propertyName
@property-read MyType|string $property_Name
@property-write MyType|string $propertyName
@property-readwrite MyType|string $propertyName";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}