import Foundation
let pattern = #"[ \t*]* @property[-]*(read|write|readwrite)?[ \t]+ ([\w\|]*)[ \t]+ ([\$\w]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
@property MyType|string $propertyName
@property-read MyType|string $property_Name
@property-write MyType|string $propertyName
@property-readwrite MyType|string $propertyName
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}