const regex = /[ \t*]* @property[-]*(read|write|readwrite)?[ \t]+ ([\w\|]*)[ \t]+ ([\$\w]*)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[ \\t*]* @property[-]*(read|write|readwrite)?[ \\t]+ ([\\w\\|]*)[ \\t]+ ([\\$\\w]*)', 'm')
const str = `@property MyType|string \$propertyName
@property-read MyType|string \$property_Name
@property-write MyType|string \$propertyName
@property-readwrite MyType|string \$propertyName`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}