$re = '/[ \t*]* @property[-]*(read|write|readwrite)?[ \t]+ ([\w\|]*)[ \t]+ ([\$\w]*)/mx';
$str = '@property MyType|string $propertyName
@property-read MyType|string $property_Name
@property-write MyType|string $propertyName
@property-readwrite MyType|string $propertyName';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);