package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[ \t*]* @property[-]*(read|write|readwrite)?[ \t]+ ([\w\|]*)[ \t]+ ([\$\w]*)`)
var str = `@property MyType|string $propertyName
@property-read MyType|string $property_Name
@property-write MyType|string $propertyName
@property-readwrite MyType|string $propertyName`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}