import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^:\\n]+://)?([^:#/\\n]*)";
final String string = "http://www.google.com/\n"
+ "https://www.google.com:2000/\n"
+ "http://100.1.25.3:8000/foo/bar?abc.php=xxxx+xxxx\n"
+ "www.google.com\n"
+ "10.0.2.2:5000\n"
+ "localhost/\n"
+ "localhost/foo\n"
+ "google.com\n"
+ "http://///x";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}