// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[^:\n]+://)?([^:#/\n]*)").unwrap();
let string = "http://www.google.com/
https://www.google.com:2000/
http://100.1.25.3:8000/foo/bar?abc.php=xxxx+xxxx
www.google.com
10.0.2.2:5000
localhost/
localhost/foo
google.com
http://///x";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}