re = /^(?:[^:\n]+:\/\/)?([^:#\/\n]*)/m
str = 'http://www.google.com/
https://www.google.com:2000/
http://100.1.25.3:8000/foo/bar?abc.php=xxxx+xxxx
www.google.com
10.0.2.2:5000
localhost/
localhost/foo
google.com
http://///x'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end