#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^\s*#.*)|(\s#.*)"
Local $sString = "#first test comment" & @CRLF & _
" # another comment" & @CRLF & _
" #indented comment" & @CRLF & _
"set whatever,cfvewicnw#shouldwork" & @CRLF & _
"" & @CRLF & _
"# ^^ empty line" & @CRLF & _
"get ndxcwiencdow # removes this comment"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)