// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^\s*#.*)|(\s#.*)").unwrap();
let string = "#first test comment
# another comment
#indented comment
set whatever,cfvewicnw#shouldwork
# ^^ empty line
get ndxcwiencdow # removes this comment";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}