import re
regex = re.compile(r"(^\s*#.*)|(\s#.*)")
test_str = ("#first test comment\n"
" # another comment\n"
" #indented comment\n"
"set whatever,cfvewicnw#shouldwork\n\n"
"# ^^ empty line\n"
"get ndxcwiencdow # removes this comment")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)