re = /(^\s*#.*)|(\s#.*)/
str = '#first test comment
# another comment
#indented comment
set whatever,cfvewicnw#shouldwork
# ^^ empty line
get ndxcwiencdow # removes this comment'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result