using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\s*#.*)|(\s#.*)";
string substitution = @"";
string input = @"#first test comment
# another comment
#indented comment
set whatever,cfvewicnw#shouldwork
# ^^ empty line
get ndxcwiencdow # removes this comment";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}