$re = '/(^\s*#.*)|(\s#.*)/';
$str = '#first test comment
# another comment
#indented comment
set whatever,cfvewicnw#shouldwork
# ^^ empty line
get ndxcwiencdow # removes this comment';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;