#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.(?=\h*[A-Z])|\R+"
Local $sString = "This is a dummy text. And it has a new line in it " & @CRLF & _
" it also has dots. Byt not." & @CRLF & _
"" & @CRLF & _
"This is a dummy text. And it has a new line in it \n it also has dots . like this."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")