using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?=\h*[A-Z])|\R+";
string input = @"This is a dummy text. And it has a new line in it
it also has dots. Byt not.
This is a dummy text. And it has a new line in it \n it also has dots . like this.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}