import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.(?=\\h*[A-Z])|\\R+";
final String string = "This is a dummy text. And it has a new line in it \n"
+ " it also has dots. Byt not.\n\n"
+ "This is a dummy text. And it has a new line in it \\n it also has dots . like this.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}