re = /\.(?=\h*[A-Z])|\R+/m
str = 'This is a dummy text. And it has a new line in it
it also has dots. Byt not.
This is a dummy text. And it has a new line in it \\n it also has dots . like this.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end