const regex = /\.(?=\h*[A-Z])|\R+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?=\\h*[A-Z])|\\R+', 'gm')
const str = `This is a dummy text. And it has a new line in it
it also has dots. Byt not.
This is a dummy text. And it has a new line in it \\n it also has dots . like this.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}