$re = '/\.(?=\h*[A-Z])|\R+/m';
$str = 'This is a dummy text. And it has a new line in it
it also has dots. Byt not.
This is a dummy text. And it has a new line in it \\n it also has dots . like this.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);