use strict;
my $str = '.selector(@background, height, font "font-family, font family", @width : 10px, "red");';
my $regex = qr/^.*?\(|,(?=(?:[^"]*"[^"]*")*[^"]*$)|\).*$/mip;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";