re = /^.*?\(|,(?=(?:[^"]*"[^"]*")*[^"]*$)|\).*$/mi
str = '.selector(@background, height, font "font-family, font family", @width : 10px, "red");'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result