import Foundation
let pattern = #"^.*?\(|,(?=(?:[^"]*"[^"]*")*[^"]*$)|\).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #".selector(@background, height, font "font-family, font family", @width : 10px, "red");"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)