$re = '/^.*?\(|,(?=(?:[^"]*"[^"]*")*[^"]*$)|\).*$/mi';
$str = '.selector(@background, height, font "font-family, font family", @width : 10px, "red");';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;