using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"PHOTO.*Jggg==\n";
string substitution = @"";
string input = @"truc a garder
PHOTO trucs a supprimer Jggg==
PHOTO trucs a garder
truc a garder Jggg==
PHOTO trucs a supprimer Jggg==
truc a garder";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}