import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "PHOTO.*Jggg==\\n";
final String string = "truc a garder\n"
+ "PHOTO trucs a supprimer Jggg==\n"
+ "PHOTO trucs a garder\n"
+ "truc a garder Jggg==\n"
+ "PHOTO trucs a supprimer Jggg==\n"
+ "truc a garder";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}