const regex = /PHOTO.*Jggg==\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('PHOTO.*Jggg==\\n', 'gm')
const str = `truc a garder
PHOTO trucs a supprimer Jggg==
PHOTO trucs a garder
truc a garder Jggg==
PHOTO trucs a supprimer Jggg==
truc a garder`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);