package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)PHOTO.*Jggg==\n`)
var str = `truc a garder
PHOTO trucs a supprimer Jggg==
PHOTO trucs a garder
truc a garder Jggg==
PHOTO trucs a supprimer Jggg==
truc a garder`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}