// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)PHOTO.*Jggg==\n").unwrap();
let string = "truc a garder
PHOTO trucs a supprimer Jggg==
PHOTO trucs a garder
truc a garder Jggg==
PHOTO trucs a supprimer Jggg==
truc a garder";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}