# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<img\s[\w\d\W]+?>){1,}/<div class="some_class">$0<\/div>/g;t' <<< "text text text text text <img scr=\"kotik.jpg\" alt=\"котяра\"/> text text text
text text text text text <img scr=\"pesik.jpg\" alt=\"пёс\"/><img scr=\"popugaichik.jpg\" alt=\"птица\"/><img scr=\"zmeika.jpg\" \"змея\"/> text text text
"