package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<img\s[\w\d\W]+?>){1,}`)
var str = `text text text text text <img scr="kotik.jpg" alt="котяра"/> text text text
text text text text text <img scr="pesik.jpg" alt="пёс"/><img scr="popugaichik.jpg" alt="птица"/><img scr="zmeika.jpg" "змея"/> text text text
`
var substitution = "<div class="some_class">$0</div>"
fmt.Println(re.ReplaceAllString(str, substitution))
}