$re = '/(<img\s[\w\d\W]+?>){1,}/';
$str = 'text text text text text <img scr="kotik.jpg" alt="котяра"/> text text text
text text text text text <img scr="pesik.jpg" alt="пёс"/><img scr="popugaichik.jpg" alt="птица"/><img scr="zmeika.jpg" "змея"/> text text text
';
$subst = "<div class=\"some_class\">$0</div>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;