const regex = /(<img\s[\w\d\W]+?>){1,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<img\\s[\\w\\d\\W]+?>){1,}', 'g')
const str = `text text text text text <img scr="kotik.jpg" alt="котяра"/> text text text
text text text text text <img scr="pesik.jpg" alt="пёс"/><img scr="popugaichik.jpg" alt="птица"/><img scr="zmeika.jpg" "змея"/> text text text
`;
const subst = `<div class="some_class">$0</div>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);